Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 09, 2026 - 06:00 EDT
Scheduled
We will be undergoing scheduled maintenance during this time to improve system performance and reliability for Prophix One in US West region. During the scheduled maintenance period, the Prophix One FP&A Plus application will be unavailable.
We apologize in advance for any inconvenience this may cause. If you have questions or concerns, please contact us at https://support.prophix.com.
Posted May 08, 2026 - 08:33 EDT
This scheduled maintenance affected: Prophix One (US2-01) (FP&A Plus (US2-01)).