The FP&A 2026.1 release is new rescheduled to March 28, 2026.
Posted Jan 27, 2026 - 15:27 EST
Update
We will be undergoing scheduled maintenance during this time.
Posted Jan 20, 2026 - 09:53 EST
Scheduled
We'll be deploying the Prophix FP&A 2026.1 Release to production. During the scheduled maintenance period, the Prophix Cloud Service will be unavailable.