Scheduled maintenance is still in progress. We will provide updates as necessary.
Posted Apr 01, 2025 - 22:01 EDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 01, 2025 - 23:00 EDT
Scheduled
We'll be deploying the Prophix One 2025.3.3 to production in all regions . During the scheduled maintenance period, the Prophix One Accounts Reconciliation will be unavailable.